Skip to menu

본문시작



질문하기 전에 검색하세요(Search before asking a question)


Views 456 Votes 1 Comment 9
?

Shortcut

PrevPrev Article

NextNext Article

Larger Font Smaller Font Up Down Go comment Print Attachment
?

Shortcut

PrevPrev Article

NextNext Article

Larger Font Smaller Font Up Down Go comment Print Attachment

1080p로고.png

샤나인코더로 로고를 넣을때 페이드 시간을 넣어서 자연스럽게 나타나도록 하는데, 페이드인아웃 하는 순간에 로고가 검은색 계열을 띱니다.

마치 검은 바탕에서 로고가 페이드인으로 나타나는 것처럼...

제가 첨부한 로고 TEST 영상을 보시면 알 수 있습니다. 하늘색 배경인데도 로고만 검게 나타나더라고요.

혹시 몰라 로고 png파일도 첨부했는데, 투명 바탕에 흰 글씨라서 본문에서는 아마 안보이겠네요 ㅎㅎ;;

검색해보니 포토샵으로 로고 png파일을 저장할때 인터레이스 체크해제하라던데, 그렇게 했는데도 그러네요.

영상 문제인가 싶기도 했는데 어떤 영상이든 증상이 나타나는걸 보면 영상 문제는 아니었습니다.

뭐 로고 넣을일이 자주 있진 않지만.. 원래 그런건지 해결할 수 있는 문제인지 궁금합니다.

 

캡처.PNG

설정은 이렇게 했습니다

이 글을 추천한 사람
JKyle
Atachment
Attachment '3'
Facebook Twitter Pinterest Kakao
  • ?
    JKyle 2021.02.05 10:20

    저도 궁금해서 확인해봤습니다.

     

    첨부하신 로고 해상도가 너무 커서 120x70으로 자르고 동일한 설정으로 샤나인코더에서 한 번, FFmpeg에서 한 번, 이렇게 로고를 넣어봤는데 페이드인/페이드아웃 시 검은색으로 변색되는 건 샤나인코더뿐이었습니다. 이게 FFmpeg 라이브러리의 문제인지, 샤나인코더 내 로고 삽입 설정에 적용된 매개변수 설정의 문제인지는 모르겠네요.

     

     

    @Rina 님이 한번 보셔야 할 듯합니다.

  • ?
    JKyle 2021.02.05 10:38

    참고로, FFmpeg로 로고 삽입한 영상입니다.

     

     

    배경이 밝은 페이드아웃 부분에서 깔끔하게 떨어지는 걸 볼 수 있습니다.

     

    이건 샤나인코더로 로고 삽입한 영상:

     

     

    배경이 밝은 페이드아웃 부분에서 회색 잔상이 남는 걸 볼 수 있습니다.

     

  • ?
    JKyle 2021.02.05 10:49

    실행한 FFmpeg 명령어는 다음과 같습니다.

     

    ffmpeg -ss 15.01 -i "test.mkv" -loop 1 -i "로고.png" -filter_complex "[0:v]scale=1280:720:flags=bicubic[o];[1]fade=t=in:st=1:d=1:alpha=1,fade=t=out:st=8:d=1:alpha=1[lo];[o][lo]overlay=5:5:shortest=1" -t 13.51 -an -c:v libx264 -y "test_logo.mp4"

    • 정지 이미지인 로고를 -loop 1 설정으로 무한루프로 돌리고, overlay 필터에서 shortest=1 설정으로 배경 영상이 끝나면 처리가 끝나도록 합니다.
    • 배경 영상은 해상도 변경
    • 로고 페이드인/아웃이 알파 채널(투명도)에만 적용되도록 alpha=1 설정

     

    나머지는 구간 자르기와 오디오 없애기, x264 인코딩 기본 설정입니다.

  • ?
    Rina 2021.02.05 11:12
    감사합니다 ^^
  • ?
    Rina 2021.02.05 11:09

    다음 버전에서 로고의 페이드 부분에 alpha 값을 넣을게요.

    현재 alpha 값이 적용되어 있지 않아서 발생한 부분입니다.

  • ?
    JKyle 2021.02.06 00:57

    출력 시간 설정 적용도 조정이 필요하지 않을까 싶습니다.

    현재 종료시간을 9초, 페이드아웃을 1초로 설정하면 로고가 9초부터 페이드아웃이 적용돼서 10초에 끝납니다.
    그와 반대로 페이드인의 경우엔 시작시간 1초, 페이드인 1초라면, 1초에 페이드인이 시작해서 정작 로고가 드러나는 부분은 2초가 됩니다.
    두 설정이 일관성이 있어야 하지 않나 싶군요. 제 생각엔 페이드인/아웃이 로고 재생 시간 내에 포함되는 게 맞지 않나 싶습니다.

    위의 FFmpeg와 샤나인코더 영상의 페이드아웃 시점이 1초가 엇갈리는 이유가 이것 때문입니다.

    ※ 에디터 컴포넌트를 바꾸셨는지 다크 테마가 디폴트로 적용되는군요. 그리고 몇몇 한글 폰트도 보이지 않습니다. 쓰기 약간 불편하네요. 현재 개편 진행 중이신 건가요? 🙄

  • ?
    Rina 2021.02.06 01:42
    로고의 시작, 종료시간은 각각 로고가 나타나고 사라지는 이벤트의 시, 종점을 기준으로 하였어요.
    그래서 페이드 인과 아웃은 시작하고 몇 초 동안 나타나고 종료하고 몇 초 동안 사라진다는 개념으로요.
    해당 부분을 바꾸면 기존에 사용했던 분들도 설정을 바꾸어야 할 것 같아 조심스럽게 되네요. ㅠㅠ

    기존에 사용했던 XE는 2020년 이후로 업데이트가 이루어지지 않고 있어서 Rhymix로 업데이트하였습니다.
    이유는 Rhymix가 XE 기반이면서도 취약점 패치가 이루어지고 있어서 보안 측면에서도 업데이트를 하는 것이 낫기 때문입니다.
    이전에 수동으로 고쳤던 XE 코드들은 Rhymix로 업데이트하면서 사라졌으므로 다시 수동으로 추가해야 해서 개편하는 데 시간이 걸리네요.
  • ?
    JKyle 2021.02.06 02:36

    그렇군요. 잘 알겠습니다.
    다만 저와 같이 오해하는 분들이 있을지 모르니 로고 설정 창에 간단하게라도 해당 설명이 추가돼야 하지 않을까 싶네요.
    저는 종료시간이 로고가 '완전히' 사라지는 시간이라고 이해했거든요. 그래서 FFmpeg에도 그렇게 설정해서 샤나에서와 결과가 달라졌네요.
    (사실 로고를 쓸 일이 거의 없어서 이번에야 제대로 써봤습니다. 😅)

    에디터 컴포넌트 문제야 뭐 급할 것도 없으니 괜찮습니다. 😃

  • ?
    Melon 2021.02.05 13:44

    두분 다 감사합니다^^ 개선될 수 있다니 다행이네요


List of Articles
No. Category Subject Author Date Views Votes
Notice 자유게시판에서는 자유롭게 글을 작성할 수 있지만 다음과 같은 내용은 삭제돼요 Rina 2020.03.18 1826 2
Notice 일반 [필독] 질문 전에 반드시 읽으세요!!! 2 file JKyle 2019.09.16 7917 5
Notice 일반 [알림] 질문 먹튀하지 마시기 바랍니다 => 본문 변경 금지 16 JKyle 2018.10.12 8902 11
2442 질문 인코딩 시작시 오류 (포타블 프로그램일때는 정상, 아닐때는 오류) 5 soohyun 2021.02.18 488 0
2441 질문 HEVC 방식 인코딩은 CPU 고화질 프리셋 없을까요? 1 TOME 2021.02.18 707 0
2440 질문 동영상과 오디오 파일을 합칠수 있나요? 1 정감독 2021.02.17 458 0
2439 질문 동영상 정보만 보고도 똑같은 설정으로 인코딩 가능한가요? 1 file 이잉주준 2021.02.16 382 0
2438 질문 아이리버 mp4 프리셋이 있나요? 1 S100 2021.02.15 295 0
2437 일반 자막 인코딩할 때 자막 배경의 투명도를 조절할 수 있으면 좋을 것같아요! 3 우수믹 2021.02.14 324 0
2436 질문 같은 사양(cpu.ram) 에 그래픽카드만 약간 다른 pc 2대에서 인코딩 속도가 너무 차이가 납니다. 1 file 영이아빠 2021.02.11 698 0
2435 질문 yuv422 format (uyvy, vyuy 등) 데이터를 lossless coding 가능한 setup이 있을까요? 2 ghanjang 2021.02.10 441 0
2434 질문 720p 자체자막 동영상 질문 급합니다ㅠㅠ 1 strelka11 2021.02.09 519 0
2433 질문 MP4 내장자막 인코딩시 자막 지연 오류 1 JK 2021.02.06 506 0
2432 질문 구간설정할때 시작시간과는 다른지점에서 잘립니다... 2 아렌티 2021.02.04 522 0
» 질문 로고 페이드 설정시 원래 검은색을 띠면서 나타나나요? 9 file Melon 2021.02.04 456 1
2430 질문 내장자막 이미지(vobsub) 영상에 자막 입히기 오류 1 everling 2021.02.04 376 0
2429 질문 도와주세요! 팟플레이어 재생은 정상 에디우스 타임라인 끊김 1 네오에딧 2021.02.02 324 0
2428 질문 인코딩 중 멈춤 증상 5 file 카카시 2021.02.01 394 0
2427 정보 3950x Vs 5950x 1 file 핀다 2021.02.01 383 1
2426 질문 인코딩 오류입니다 1 태룡2 2021.01.31 325 0
2425 질문 샤나인코더 합치기 질문... masteryi 2021.01.29 254 0
2424 정보 VVC도 HEVC 꼴 나는 것 같네요 JKyle 2021.01.29 562 0
2423 질문 이 영상이랑 똑같은 설정으로 인코딩하고 싶은데 어떻게 설정해야 하나요? file 숑송 2021.01.28 287 0
Board Pagination Prev 1 2 3 4 5 6 7 8 9 10 ... 127 Next
/ 127