Skip to menu

본문시작



질문하기 전에 검색하세요(Search before asking a question)


Views 382 Votes 0 Comment 3
?

Shortcut

PrevPrev Article

NextNext Article

Larger Font Smaller Font Up Down Go comment Print Attachment
?

Shortcut

PrevPrev Article

NextNext Article

Larger Font Smaller Font Up Down Go comment Print Attachment

Hello.

I have a problem with the original setting (unter 5.1):

(Copy)\Stream Copy to Mp4.xml

-----

Encoding setting:

 -f mp4 -c:v copy -c:a copy -sn

-----

If I copy my video file wiht this setting I lost my cover into the file.

Please: What is the right encoding setting that my file not lost the cover?

lost_cover.jpg

 

Thanks for your help.

Regards.

Atachment
Attachment '1'
Facebook Twitter Pinterest Kakao
  • ?
    Prophet 2020.10.08 02:18

    mediainfo of original video?

  • ?

    1. You need to include the cover 'stream' as well by right-clicking the file in the list and selecting Video/Audio stream selection.

     

    Shana_5.1.0.0_preserve-cover_stream-copy_1_20201007.jpg

    Shana_5.1.0.0_preserve-cover_stream-copy_2_20201007.jpg

    Otherwise, your cover image stream is not included in your final output.

     

    At the end of this step, you need to check the 'location' of your cover image in the output.

    In the example above, the cover image becomes the second video stream in the output, so its stream specifier ID is v:1, where v means video, and 1 means the order. (The stream index starts at 0).

     

    2. Specify the cover stream as an attached picture in Encoding Settings of the Parameters window.

    Just add this additional parameter setting there. (Start with a blank space.)

     -disposition:v:1 attached_pic

    Shana_5.1.0.0_preserve-cover_stream-copy_3_20201007.jpg

     

    That's it.

  • ?
    AT23 2020.10.08 23:04
    YES! - This is it!
    -disposition:v:1 attached_pic
    and with the selecting Video/Audio stream

    I hope soo that the nice Shana Encoder make this option in a new version
    automatically and did not delete my cover by copying..
    Big thanks again.

List of Articles
No. Subject Author Date Views Votes
Notice This bulletin board is for users of English version of ShanaEncoder 3 Rina 2019.07.24 631 1
47 Subtitle alignment wrong 2 updatefile stax 2020.11.27 12 0
» Encoding settings (lost my cover) 3 file AT23 2020.10.07 382 0
45 The default audio sample rate is now 48khz instead of 44.1khz 小樱 2020.09.26 217 0
44 add CPUToolStripMenuItem 1 file 小樱 2020.09.26 152 0
43 I found a windows file explorer bug. 2 file chessset5 2020.08.04 692 0
42 Recovering the file list after errors. Yar 2020.07.17 325 0
41 Direct Copy Audio Error from 4K to 2K mkv 1 Gedeon 2020.05.08 742 0
40 The output mp4 sound picture is out of sync error 小樱 2020.04.30 893 0
39 is there an "optimized web" option ?? 1 aisa 2020.04.29 539 0
38 Can you add this function? 1 file wangYu 2020.04.04 538 0
37 480P MKV X265 33MB <-- Found It, Just Need Some Answer Of A Line.. 5 SyXaTz 2020.04.03 938 0
36 AUDIO missing function (request) bata 2020.04.02 556 0
35 Cropping 2 chessset5 2020.03.25 300 0
34 import external audio bata 2020.02.20 357 0
33 Best settings for transcoding 4k HDR content 2 daclina 2020.02.20 1148 0
32 Error encoding when use custom preset 4 file Panji 2019.11.16 1246 0
31 Is It Possible To Transcode Multiple Videos Simultaniously? 1 JensanHuang 2019.11.12 678 1
30 Request: Additional audio feature PeterP 2019.09.18 908 0
29 Support of the aom av01 codec Yar 2019.09.11 919 0
28 Suggestion2:There are three items av1 2019.08.26 817 0
Board Pagination Prev 1 2 3 Next
/ 3